勢いでrspec2をインストールしてしまったんだけど(ついでにRails3も入った)、その状態だとrspec1由来のspecがrspec2のgemを読み込もうとしてエラーになる。
解決するには、spec(/usr/bin/specとか、rvm環境なら~/.rvm/gems/ruby-*/bin/spec)を直接書き換えて


version = “< 2.0.0" [/ruby] を指定してしまえばいい。 しかし、もう全然別物と言ってもいいんだからgem名も変えてほしかったなぁ…

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

2019 Proxima Fermata. All rights reserved.
Design by picomol. Powered by WordPress.